Low output voltage in 2nd set of DropBot system


#1

Dear all,

Now I’m installing 2nd DropBot system and facing strange trouble. Output voltage is low, around 1/3 of setted value. Just after Real-time-mode checking, “failed to achieve the specified voltage” message was popped up. Profile log also says the same message like attached file(log.txt).

My installation record is following.

(1) signal generator

Using Arduino-IDE and FTDI cable, boot-loader and firmware are burned succesfully.

Board calibration was carried out. 5Vp-p output is adjusted to 250mV by set_pot command.

(2) HV switching board

Boot-loader and firmware are burned. Serial monitor output looks OK.

(3) controler board

Stacked on Arduino MEGA and firmware was flashed. Firmware was confirmed using Arduino IDE.

(4) Building up and cabling of DropBot

(5) channel_test, calibration_device_load, calibration_reference_load were carried out. Each results looks correct like attached pictures(ch_test.jpg, calib_device_load.jpg, calib_ref_load.jpg).

(6) Low voltage was found at 1st trial of experiment.

Internal node waveform of signal generator board were monitored to investigate the reason for both working 1st system and 2nd one with trouble(waveform comp.docx).

It seems to show that low pass filter function is working well but there might be some errors in amplitude adjustment circuit. However, it looks strange the calibration steps(5) look OK.

I’d like to have your advise to debug this issue and suggestion about another check point and/or testing.

Thanks,

Aki @Univ. of Tokyo.

log.txt (16.5 KB)

waveform comp.docx (1.48 MB)


#2

Hi Aki,

Happy new year! Can you check if you have the Auto_adjust_amplifier_gain check box ticked in Tools/DMF control board/Configuration/Edit settings?

-Ryan

···

On Thu, Dec 28, 2017 at 8:43 AM, ytoyo...@nojilab.t.u-tokyo.ac.jp wrote:

Dear all,

Now I’m installing 2nd DropBot system and facing strange trouble. Output voltage is low, around 1/3 of setted value. Just after Real-time-mode checking, “failed to achieve the specified voltage” message was popped up. Profile log also says the same message like attached file(log.txt).

My installation record is following.

(1) signal generator

Using Arduino-IDE and FTDI cable, boot-loader and firmware are burned succesfully.

Board calibration was carried out. 5Vp-p output is adjusted to 250mV by set_pot command.

(2) HV switching board

Boot-loader and firmware are burned. Serial monitor output looks OK.

(3) controler board

Stacked on Arduino MEGA and firmware was flashed. Firmware was confirmed using Arduino IDE.

(4) Building up and cabling of DropBot

(5) channel_test, calibration_device_load, calibration_reference_load were carried out. Each results looks correct like attached pictures(ch_test.jpg, calib_device_load.jpg, calib_ref_load.jpg).

(6) Low voltage was found at 1st trial of experiment.

Internal node waveform of signal generator board were monitored to investigate the reason for both working 1st system and 2nd one with trouble(waveform comp.docx).

It seems to show that low pass filter function is working well but there might be some errors in amplitude adjustment circuit. However, it looks strange the calibration steps(5) look OK.

I’d like to have your advise to debug this issue and suggestion about another check point and/or testing.

Thanks,

Aki @Univ. of Tokyo.

You received this message because you are subscribed to the Google Groups “dropbot-dev” group.

To unsubscribe from this group and stop receiving emails from it, send an email to dropbot-dev+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


#3

Ryan,

Thank you for your reply. I hope new year will be fruitful for you!

I’ve checked configuration setting table.

“Auto_adjust_amplifier_gain” check box is “off”. Is there any other point of check?

Regards,

Aki

···

#4

Hi Aki,

Please turn on the Auto_adjust_amplifier_gain check box and try again.

Since the gain of an amplifier is non-linear with respect to, e.g,. load, frequency, etc., the DropBot provides optional closed-loop actuation voltage control as indicated in the diagram below:

When auto_adjust_amplifier_gain is enabled, the actual output voltage is measured and the modeled amplifier voltage is adjusted to account for any deviations due to load (e.g., number of electrodes), frequency, etc.

Hopefully this helps!

Cheers,
Christian

···

On Wed, Jan 3, 2018 at 8:44 PM, ytoyo...@nojilab.t.u-tokyo.ac.jp wrote:

Ryan,

Thank you for your reply. I hope new year will be fruitful for you!

I’ve checked configuration setting table.

“Auto_adjust_amplifier_gain” check box is “off”. Is there any other point of check?

Regards,

Aki

You received this message because you are subscribed to the Google Groups “dropbot-dev” group.

To unsubscribe from this group and stop receiving emails from it, send an email to dropbot-dev+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


#5

Christian,

Checking “Auto_adjust_amplifier_gain” check box, desired output voltage was obtained!

Thanks a lot for your quick advice!

Let me know why this closed-loop control is optional. It looks enough to be default.

Regards,

Aki

2018年1月4日木曜日 11時55分30秒 UTC+9 Christian Fobel:

···

Hi Aki,

Please turn on the Auto_adjust_amplifier_gain check box and try again.

Since the gain of an amplifier is non-linear with respect to, e.g,. load, frequency, etc., the DropBot provides optional closed-loop actuation voltage control as indicated in the diagram below:

Inline image 1

When auto_adjust_amplifier_gain is enabled, the actual output voltage is measured and the modeled amplifier voltage is adjusted to account for any deviations due to load (e.g., number of electrodes), frequency, etc.

Hopefully this helps!

Cheers,
Christian

On Wed, Jan 3, 2018 at 8:44 PM, ytoyo...@nojilab.t.u-tokyo.ac.jp wrote:

Ryan,

Thank you for your reply. I hope new year will be fruitful for you!

I’ve checked configuration setting table.

“Auto_adjust_amplifier_gain” check box is “off”. Is there any other point of check?

Regards,

Aki

You received this message because you are subscribed to the Google Groups “dropbot-dev” group.

To unsubscribe from this group and stop receiving emails from it, send an email to dropbot-dev...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


#6

It’s optional because it does have some limitations (it can cause the output voltage to jump around a bit); for amplifiers with uniform gain, you may get a more stable output by leaving it unchecked and setting the gain manually.

It also doesn’t make sense to have it checked before your instrument is calibrated because it can actually make things worse in this case.

I hope that helps?

-Ryan

···

On Wed, Jan 3, 2018 at 11:31 PM, ytoyoshima@nojilab.t.u-tokyo.ac.jp wrote:

Christian,

Checking “Auto_adjust_amplifier_gain” check box, desired output voltage was obtained!

Thanks a lot for your quick advice!

Let me know why this closed-loop control is optional. It looks enough to be default.

Regards,

Aki

2018年1月4日木曜日 11時55分30秒 UTC+9 Christian Fobel:

Hi Aki,

Please turn on the Auto_adjust_amplifier_gain check box and try again.

Since the gain of an amplifier is non-linear with respect to, e.g,. load, frequency, etc., the DropBot provides optional closed-loop actuation voltage control as indicated in the diagram below:

When auto_adjust_amplifier_gain is enabled, the actual output voltage is measured and the modeled amplifier voltage is adjusted to account for any deviations due to load (e.g., number of electrodes), frequency, etc.

Hopefully this helps!

Cheers,
Christian

On Wed, Jan 3, 2018 at 8:44 PM, ytoy...@nojilab.t.u-tokyo.ac.jp wrote:

Ryan,

Thank you for your reply. I hope new year will be fruitful for you!

I’ve checked configuration setting table.

“Auto_adjust_amplifier_gain” check box is “off”. Is there any other point of check?

Regards,

Aki

You received this message because you are subscribed to the Google Groups “dropbot-dev” group.

To unsubscribe from this group and stop receiving emails from it, send an email to dropbot...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups “dropbot-dev” group.

To unsubscribe from this group and stop receiving emails from it, send an email to dropbot-dev+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


#7

Ryan,

I understand your careful design.

Thank you!

Aki