Device svg file load error


#1

Hi Christian,

I’m facing device data loading trouble again. Pop-up error message like ‘load error.jpg’ shows up at svg file load fo MicroDrop.

svg file had been prepared by following steps according to the MicroDrop 2.0 procedure.

  1. ‘RTA_elementf.dxf’ file was made from device CAD data. Format is ‘AutoCAD 2000/LT 2000 DXF’.

  2. Using Inkspace 0.91, layout data was moved to the Device layer and saved as ‘RTA_elementf.svg’.

  3. svg file is loaded by MicroDrop2.4 by File>Device>Load menu but error message is popped up.

log message in the profile is ‘log.txt’

There might be something wrong in device data but I couldn’t find.

I’d like to have your advice.

Regards,

RTA_elementf.dxf (504 KB)

log.txt (1.62 KB)


#2

Hi Christian,

Trouble has been solved by work around.

To identify the object causing error, some element data on svg file was deleted and loading to DropBot was examined. After the several times trial, I found just one element data is causing error. Omitting this element, loading was made successfully like ‘RTAelement b.jpg’.

After removal of this element and re-write the rectangle data, desired device data is loaded into DropBot as ‘RTAelement a.jpg’.

The root cause is still not clear because there seems to be no difference between old and revised rectangle data.

Thanks,

Aki@U-Tokyo