Device data import in Microdrop 2.0


#1

Hi Christian, Ryan,

Let me ask another question regarding device data import.

According to the “User Guide”, I tried to register my device svg file choosing “File/device/import”.

However, *.svg extension is not allowed this page.

It is accepted in “File/device/load” page but nothing show up in the device user interface window.

Corresponding folder was made in \MicroDrop\devices folder.

My device data (40pinEl.svg) is the same one used in Microdrop1.0.

Is there any different requirement in Microdrop2.0 ?

I’d like to attach my device svg file. could you comment on this?

Regards,

Aki@U-Tokyo


#2

Hi Aki,

In MicroDrop v2.0, device files are now Inkscape SVG files where the electrode paths are drawn on a layer named “Device”. The device import in MicroDrop v2.0 accepts MicroDrop v1.0 device files. If you have a device file that you were using in MicroDrop v1.0 (under Microdrop\devices in your MicroDrop v1.0 settings directory), you can import that. Otherwise, you can try to:

  • In Inkscape, create a layer called “Device” in your SVG file.
  • Move all electrode paths to the “Device” layer.
  • Make sure the Inkscape settings from the “User guide” are set (e.g., use absolute commands).
  • Save SVG.
  • Load SVG from “File > Device > Load” menu in MicroDrop v2.0
    I am busy until after lunch today, but I will take a look at your SVG file this afternoon and will make sure it loads in MicroDrop v2.0, if you can wait until then.

Note that I will be updating the “User guide” soon to with a detailed description of the new device file format, but haven’t had a chance yet.

Cheers,
Christian

PS - I saw your other email, but won’t have a chance to respond until this afternoon. My first impression though is that the error might have been a fluke, since I would expect the calibration steps to fail if one of the channels was actually bad (note that we typically test the channels before calibration, to test for shorts/bad channels that would affect the calibration).

···

On Fri, Nov 25, 2016 at 5:18 AM, ytoyo...@nojilab.t.u-tokyo.ac.jp wrote:

Hi Christian, Ryan,

Let me ask another question regarding device data import.

According to the “User Guide”, I tried to register my device svg file choosing “File/device/import”.

However, *.svg extension is not allowed this page.

It is accepted in “File/device/load” page but nothing show up in the device user interface window.

Corresponding folder was made in \MicroDrop\devices folder.

My device data (40pinEl.svg) is the same one used in Microdrop1.0.

Is there any different requirement in Microdrop2.0 ?

I’d like to attach my device svg file. could you comment on this?

Regards,

Aki@U-Tokyo

You received this message because you are subscribed to the Google Groups “dropbot-dev” group.

To unsubscribe from this group and stop receiving emails from it, send an email to dropbot-dev+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


#3

Hi Aki,

I performed the steps that I outlined in my previous email for the SVG file you provided and was successfully able to load the device SVG file in MicroDrop v2.0.

Note that you will need to assign the associated channel number to each electrode (right-click on the electrode in the device view and select Edit electrode channels...).

Please let me if the you are able to load the attached SVG file device.

Thanks,
Christian

···

On Fri, Nov 25, 2016 at 7:16 AM, Christian Fobel chri...@fobel.net wrote:

Hi Aki,

In MicroDrop v2.0, device files are now Inkscape SVG files where the electrode paths are drawn on a layer named “Device”. The device import in MicroDrop v2.0 accepts MicroDrop v1.0 device files. If you have a device file that you were using in MicroDrop v1.0 (under Microdrop\devices in your MicroDrop v1.0 settings directory), you can import that. Otherwise, you can try to:

  • In Inkscape, create a layer called “Device” in your SVG file.
  • Move all electrode paths to the “Device” layer.
  • Make sure the Inkscape settings from the “User guide” are set (e.g., use absolute commands).
  • Save SVG.
  • Load SVG from “File > Device > Load” menu in MicroDrop v2.0
    I am busy until after lunch today, but I will take a look at your SVG file this afternoon and will make sure it loads in MicroDrop v2.0, if you can wait until then.

Note that I will be updating the “User guide” soon to with a detailed description of the new device file format, but haven’t had a chance yet.

Cheers,
Christian

PS - I saw your other email, but won’t have a chance to respond until this afternoon. My first impression though is that the error might have been a fluke, since I would expect the calibration steps to fail if one of the channels was actually bad (note that we typically test the channels before calibration, to test for shorts/bad channels that would affect the calibration).

On Fri, Nov 25, 2016 at 5:18 AM, ytoyoshima@nojilab.t.u-tokyo.ac.jp wrote:

Hi Christian, Ryan,

Let me ask another question regarding device data import.

According to the “User Guide”, I tried to register my device svg file choosing “File/device/import”.

However, *.svg extension is not allowed this page.

It is accepted in “File/device/load” page but nothing show up in the device user interface window.

Corresponding folder was made in \MicroDrop\devices folder.

My device data (40pinEl.svg) is the same one used in Microdrop1.0.

Is there any different requirement in Microdrop2.0 ?

I’d like to attach my device svg file. could you comment on this?

Regards,

Aki@U-Tokyo

You received this message because you are subscribed to the Google Groups “dropbot-dev” group.

To unsubscribe from this group and stop receiving emails from it, send an email to dropbot-dev+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


#4

Christian,

svg file you attached was surely suitable to the system.

I also examined file transfer by myself. Steps you described was making sense and I was be able to make new device data.

Thanks!

Aki@U-Tokyo

···

#5

No problem! Glad to hear it is working.

Thanks,

Christian

···

On Mon, Nov 28, 2016, 1:08 AM ytoyo...@nojilab.t.u-tokyo.ac.jp wrote:

Christian,

svg file you attached was surely suitable to the system.

I also examined file transfer by myself. Steps you described was making sense and I was be able to make new device data.

Thanks!

Aki@U-Tokyo

You received this message because you are subscribed to the Google Groups “dropbot-dev” group.

To unsubscribe from this group and stop receiving emails from it, send an email to dropbot-dev...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


#6

Aki, Christian:

I ran into a similar situation recently and I think part of the early confusion might the wording.

This page of the User Guide (as of 8/13/2017) says:

“Choose “File/device/import” from the menu and select your svg file.”

https://github.com/wheeler-microfluidics/microdrop/wiki/User-guide

However, as Christian explains in this thread, what’s needed is actually:

“Load SVG from “File > Device > Load” menu…”

When I first tried “import”, the dialog window expected file types for “DMF device version 0.3.0” rather than SVG. Intuitively “importing” SVG’s and “loading” DMF device files would’ve made more sense at least to me, but aside from this confusion getting SVGs into MicroDrop seems to be working fine. Having these archived messages is helpful!

-John


#7

Thanks John. Yes, the documentation is in a bit of a mess right now because some of it refers to the old device file format (stored as a “pickled” Python object in MicroDrop v1.x), whereas the new device file format is an svg with some additional metadata.

I expect that we will be making a big push to clean up the documentation over the next couple of months now that the new hardware is stable.

I also want to encourage people to edit the documentation (it’s a wiki) if you see anything that doesn’t make sense or could be improved. That’s what open source is all about!

Thanks,

-Ryan

···

On Sun, Aug 13, 2017 at 4:22 PM, John Lee sang-j...@sjsu.edu wrote:

Aki, Christian:

I ran into a similar situation recently and I think part of the early confusion might the wording.

This page of the User Guide (as of 8/13/2017) says:

“Choose “File/device/import” from the menu and select your svg file.”

https://github.com/wheeler-microfluidics/microdrop/wiki/User-guide

However, as Christian explains in this thread, what’s needed is actually:

“Load SVG from “File > Device > Load” menu…”

When I first tried “import”, the dialog window expected file types for “DMF device version 0.3.0” rather than SVG. Intuitively “importing” SVG’s and “loading” DMF device files would’ve made more sense at least to me, but aside from this confusion getting SVGs into MicroDrop seems to be working fine. Having these archived messages is helpful!

-John

You received this message because you are subscribed to the Google Groups “dropbot-dev” group.

To unsubscribe from this group and stop receiving emails from it, send an email to dropbot-dev+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.